Question i5 7600k vs BF5 continous 100% cpu usage and low fps

Nov 5, 2019
11
0
10
0
Hello everyone i have huge problem that im bothering for a few days.
It all started when I first installed battlefield 5. From the first time i have fps problems cant get more than 60+ fps on ultra. Changing video settings to low gives me even less performance around 35-45 fps. Check many different setting so i think settings is not a main problem here.
Important : My friend have the same cpu as me with lower timings and his pc is pretty similar overall and he runs bf5 smooth on ultra with 70 fps + on bigger resolution. That's why i know theres something wrong couse he can easily play.

Here's my specs and other info

CPU : i5 7600k ( overclocked atm 4.8 Ghz 1.4V) - tested 5ghz same result at the game (cpu usage 100% and fps lags)
Graphic card : asus rog strix 1070 (stock)
RAM : G.SKILL AEGIS 16GB (2X8GB) DDR4 3000MHZ CL16 (dual channel)
Motherboard : Gigabyte z270 k3 gaming
Windows 10 v 1903
Cooler : Dark rock 3
power supply : some 600W be quiet

I was thinking about power supply for cpu or something in windows which blocking my cpu performence hard.
For additional questions I'm here to help.
 
Nov 5, 2019
11
0
10
0
Yes im 100% sure and know that 4 cores and 4 threads may couse troubles. It is what it is im surpirsed for this huge difference between us.
 
Nov 5, 2019
11
0
10
0
Can't really tell you how much couse as you know cpu jumps alot with usage in idle but i guess around 20-40 %.
I can tell u more precise when i back home.
 
Nov 5, 2019
11
0
10
0
Sorry for mistake. While idle my cpu usage is about 10%. Most of time lower than 10% so i guess its all good in this case :(
 

rds1220

Splendid
Did you run anti virus to make sure there are no viruses or malware? if nothing else works you can always do a clean install of Windows will all the latest updates and drivers and see if that fixes it.
 
Nov 5, 2019
11
0
10
0
I'll try to reinstall BF5 couse i don't know what else could help. If noone got any idea what can i check more I'll reinstall windows and hope this one help fix this.
 

ASK THE COMMUNITY

TRENDING THREADS