[SOLVED] Is my graphics card dead?

Oct 28, 2019
2
0
10
0
So few months earlier my computer was running fine and the games were also running very smooth on medium to high settings depending on the games I play (Far cry series or tom clancys). Fast forward to this day i am using the same setup but no games would run more than 2-3 minutes. It would just log in to the lobby screen and whenever i started the gameplay the screen freezes for like a nano second and red dots like artifacts appear all over the screen, most of the time it crashes to desktop and some of the time it crashes the whole pc so its just stuck like crashed, the mouse wouldnt move or basically everythigns stuck. I am very frustrated and done at this point, i tried using ddu to install gpu drivers again not working, tried downclocking doesnt boot up the computer, tried installing all the necessary drivers not works.

I have the following build its old but this used to work now it doesnt.

Motherboard - Gigabyte 970 udp 3a
CPU - 8 core amd fx 8350
Ram - 12 gb of ddr3 1333mhz
GPU - AMD radeon r9 285
PSU - EVGA 500 watt gold rated
Freezer 13 CO limited edition for cooling and extra fans.


I tried to check for temps so gpu temps normally around 30 to 45

and cpu temp is around normal 30-50 ish. please give me a solution to this i am sick of it.


UserBenchmarks: Game 21%, Desk 38%, Work 29%
CPU: AMD FX-8350 - 48.1%
GPU: AMD R9 285 - 17.2%
HDD: WD Blue 250GB (2010) - 24.6%
RAM: Kingston 9905474-057.A Samsung M378B5273CH0- Corsair CMZ8GX3M2A160 12GB - 39.7%
MBD: Gigabyte GA-970A-UD3P

these benchmarks were never this bad.
 

ASK THE COMMUNITY

TRENDING THREADS