Question Laptop won't turn on (Asus s410ua)

Apr 16, 2020
12
0
10
0
I'm using my laptop for more than 2 years now. My laptop came with 128GB ssd and 1TB HDD. 128GB ssd was too low for me , so recently decide to change it to 500GB SSD. 1st attched photo was my Previous SSD and 2nd one is the new one. After removing the old and intslled my new SSD, I went back to turn my laptop and install windows. I found that my laptop was not turning on. Even with the power cable. There was no light indicate on the side that it's charging. I follow the basic steps like removing battery and hold power button for 1 minute to drain the static power. But it didn't help. I tried to do bios reset by removing CMOS but didn't even found the cmos battery in my laptop. Please check the motherboard and if anyone can tell me where can i find the cmos battery.

SSD 128GB - 3.3V 1A
SSD 500GB - 3.3V 1.7A

Please help me solve the problem as I need to work as soon as possible and it's christmas break so no repair shop is open now.
 
Apr 16, 2020
12
0
10
0
I did put the old SSD and still same issue.

OLD SSD - 128GB SKhynix N210A BB (MSIP - REM - HNX - SC308M280S)
NEW SSD - 500GB CRUCIAL P1 M.2 2280 (MDL- CT500P1SSD8)
 
So it's probably not caused by the SSD but by something during disassembly/reassembly.

Watch videos and read instructions on proper disassembly and assembly and, carefully, go in and make sure all cables have been reattached properly and look for any damages.
 
Apr 16, 2020
12
0
10
0
I did disassmble before and it worked like a charm. But this time its not. And the most annoying part is there's no light when I plugged in my charger :(
 
The problem is that it's not even powering on. No lights, no screen, nothing. A BIOS reset probably wouldn't do anything.

Have you tried completely removing the battery, holding the power button for a minute, this trying to plug it in and turn it on without the battery installed?
 
Last edited:

ASK THE COMMUNITY

Latest posts