Question PC Issue? Graphics card failure or Driver corrupt?

djoegibson01

Prominent
Dec 13, 2018
10
0
510
0
Over the last year I have had my PC monitor turn off and back on again during gameplay. Only recently it has started becoming a real pain and a massive issue in my life and work. Specs to my PC will be listed below. The few suspected things to make this happen were to be my Powercolor RX580 Red Devil, my Monitor, my PSU or drivers. I have had this PC for almost 2 years, adding bits onto it like coolers, RAM and upgrading the GPU from a GeForce 8800 GTX.

First I will talk about my monitor. I was looking for a cheap 144hz 1440p monitor. The monitor is a Chinese brand called element gaming I believe: https://www.ebuyer.com/838555-eg-27-gaming-monitor-qhd-144hz-1ms-with-amd-freesync-gs27-v2
The monitor is a TN panel I have head it for 6 months, already showing signs of staining on the screen or the bulb burning out. The main issue I face with my PC is when I load up some games, my monitor would start to flicker and shut off for 3 seconds and come back on, sometimes alt-tabbing me from games and running them at a lower resolution. The black screen to me looked like a power issue but when plugging it into my brothers machine it was fine. We ran Hell Let Loose on full ultra settings and no screen issues occurred so it cant be the monitor. The game makes my monitor shut off so it was a decent test being one game that he has installed. Simple games like CS:GO and Alien Isolation, ARMA 3, GTA V have all recently been making my screen go off which sucks, I only limit myself to those games because of this issue. One game I recently bought which I haven't had an issue on is F1 2020 which I can enjoy.

I just replaced my PSU yesterday from a 600w cheap one that had yellow cables and green endings on that I have used for 2 years. I suspected this because I had to buy an adaptor for the cables because it didn't fit the GPU, it was 2 slots short. Buying the cable resolved the issue so I could use the GPU. I upgraded my PSU to a Corsair RM750X, 80+ GOLD rated which works fine. It doesn't fit into my case but I have another one of those on its way. The issue still occurred after replacing the PSU as well.

My GPU has to be the main culprit because every time the issue happens, I hear a faint buzzing or fizzing when the screen goes off. It sounds like its coming from the GPU but not 100% sure. I do plan to upgrade my GPU later this year to a 3080 which will be a treat but I just do not wont the issue carrying over. I have updated my card to its latest drivers and every update doesn't want to fix my issue.

Last time I factory reset was aprox. 3 months ago, issue occurred before and after.
In my Radeon settings, I set all my settings to default to see if anything happens or changes.
In Control Panel, Power Options, I have Ultimate Performance mode enabled.

1 X SEAGATE BARRACUDA 2TB HDD - 771GB FREE
1 X TEAMGROUP SSD 240GB - 19.8GB FREE
MotherBoard - ROG STRIX Z390-F GAMING
CPU - Intel(R) Core(TM) i5-9600K CPU - @ 3.70GHz 6 Cores
RAM - 16 GB
GPU - Radeon RX 580 Series - Primary/Discrete
VRAM - 8192 MB - GDDR5 2000 MHz

Graphics Card Manufacturer - Powered by AMD
Graphics Chipset - Radeon RX 580 Series
Device ID - 67DF
Vendor ID - 1002
SubSystem ID - 2377
SubSystem Vendor ID - 148C
Revision ID - E7
Bus Type - PCI Express 3.0
Current Bus Settings - PCI Express 3.0 x8
BIOS Version - 015.050.000.001
BIOS Part Number - 113-C9403100_101
BIOS Date - 2017/03/31 00:09
Usable Memory Size - 8192 MB
Memory Type - GDDR5
Memory Clock - 2000 MHz
Core Clock - 1411 MHz
Total Memory Bandwidth - 256 GByte/s
Memory Bit Rate - 8.00 Gbps
2D Driver File Path - /REGISTRY/MACHINE/SYSTEM/CurrentControlSet/Control/Class/{4d36e968-e325-11ce-bfc1-08002be10318}/0001
OpenGL® API Version - 4.6
OpenCL™ API Version - 2.0

EDIT: come to think of it, every time I load up a game, the same black screen happens.
 
Last edited:

ASK THE COMMUNITY