Question Pc wont boot with RTX 2060 Super Aorus GPU installed?

Oct 18, 2019
2
0
10
0
stick with 1 thread don't spam the forum
My issue:
When I install my GPU (rtx 2060 super Aorus 8gb), the bios on my computer wont show, and the display wont connect. Just says ‘signal detected’ then ‘signal lost’ on screen. The fans and rgb lights on gpu run fine.

I am temporarily using an Amd Athlon 200ge with integrated graphics so I could update my mb bios so it can support my 3rd gen Ryzen cpu.

The computer boots fine into windows os when the graphics card is removed.

But as soon as I connect the gpu, nothing displays on screen, and even the turn off/reset buttons don’t work on the case...

Some info about the setup:
  • My psu has a single 8 pin connector which splits to 2 x 6+2 pin connectors that power the gpu. - My psu is tx550m
  • No error lights show on the mboard
What I have tried so far:
  • changed bios settings to set primary graphics to the pci slot the gpu is connected to
  • checked psu cables are all connected
  • gpu is definitely clicked in fully and in correct slot according to manual. It’s the only one it will fit anyway due to the size of it.
  • switching cpu to ryzen 7 3700x (same issue)
  • hdmi is definitely in gpu hdmi. Have tried all hdmi’s in gpu
  • bios is up to date
  • cmos reset by removing battery for 10 mins
  • Tested on 2 different monitors
Unfortunately I don’t have any spare parts other than 2 cpu’s to test.

Appreciate any help you can give. Thanks very much for reading!!

Spec of build:
  • Gigabyte X470 AORUS GAMING 5 WIFI
  • Gigabyte RTX 2060 Super Aorus 8GB
  • Corsair TX550M 550w
  • Amd athlon 200ge (and ryzen 7 3700x waiting to install once this is working)
  • G.Skill Trident Z Neo RGB 16GB (2x 8GB) DDR4 3200MHz Memory
 
Last edited:

ASK THE COMMUNITY