Question Question about Pigtail & PC Won't Turn ON!

PaPies

Distinguished
Feb 5, 2014
90
0
18,630
0
Hey, recently I've upgraded to RTX 3080 (From 1080) and I've used pigtail 8pin to get the job done, even for the RTX 3080, but I noticed it only draws 280 power instead of ~330, so I got the second cable from the box and replaced the pigtail with the standalone 8pin's and the PC won't turn on, but I do hear a click.
 

PaPies

Distinguished
Feb 5, 2014
90
0
18,630
0
Well...the 2x connections on the GPU are looking for 2x connections from the PSU.
Not 1x connection split into two.

A 3080 needs two actual connections.
Maybe you didn't understand what I said on the original post.

I've been running the RTX 3080 on a single cable that splits into two 8pins and working fine, just now I decided to use 2 seperate 8pins connected to the GPU and it won't turn on.
 
Changing from 1 PCIe 6+2 cable where you used both connection on that cable on the GPU to 2 6+2 cable where you only use 1 on each should work.

Unless there is an issue with the PSU, Cable or the GPU at the moment this should work.

If you connect it back with only 1 PCIe 6+2 cable does it work?
 

PaPies

Distinguished
Feb 5, 2014
90
0
18,630
0
Changing from 1 PCIe 6+2 cable where you used both connection on that cable on the GPU to 2 6+2 cable where you only use 1 on each should work.

Unless there is an issue with the PSU, Cable or the GPU at the moment this should work.

If you connect it back with only 1 PCIe 6+2 cable does it work?
Yeah, connecting it back to the 1 cable that is 8 pin to double 8pin works.
 

ASK THE COMMUNITY

TRENDING THREADS