[SOLVED] Windows won't install GPU drivers!

Feb 16, 2020
6
2
15
0
Okay so here is what is going on...

I was playing some Rainbow Six Siege, everything was normal and usual. First at some point, game was starting to crash, and I got 2 Crash reports which i sended to Ubisoft. Then 3rd time i opened the game and started playing, my screen turned whole white, it froze and i got some weird silver/black lines over the screen. I rebooted the PC and it loaded BIOS normally, and when it should log in in Windows 10, whole screen turns black. I heard the sound of logging in Windows, but doesn't get the picture.

First I rebooted the PC couple of times. Nothing. Next thing I did was entering in Safe Mode. Okay so here I got the picture, but when I open Device Manager > Display Adapters here it doesn't say I have my AMD Radeon R9 270X, it just says "Microsoft Basic Display Adapter". When I opened 'CPU-Z' and go to graphics there it load and display my graphic card. So when i tried to update drivers trough AMD Radeon Software Adrenaline 2020 it is starting to install drivers, but it can't complete installation and my screen turns black again, so I have to enter Safe Mode again and uninstall AMD Radeon so I can have picture again.

I even tried installing Windows 7, same problem. I reinstall Windows 10 again, same problem. I even tried to replace GPU in another PCIE slot, still nothing. I even tried another GPU "Nvidia GeForce GTX 550 Ti 1 GB and it can't install Nvidia drivers too. Windows is fully updated, and Windows Update too can't install drivers for both GPUs.

If someone know what can be the problem, or had similar experience i would be thankful that someone can help. Im stuck in a loop for days trying to figure out what is causing the problem. Is it GPU slots, motherboard, BIOS, Power Supply? I really don't know anymore.
 
more than likely the card has just recently malfunctioned. if you have the option, test the 270X in another system to make sure it is definitely the card having problems.
if it turns out still okay, at least you may get a few bucks for it towards a newer generation GPU.
 
Feb 16, 2020
6
2
15
0
list all of your system specs
CPU: Intel i5 720 @ 2.67 Ghz
MB: ASUSTeK P7P55D PRO
GPU: AMD Radeon R9 270X 2 GB (I also have EVGA Nvidia GeForce GTX 550 Ti 1GB)
RAM: 8 GB DDR3

Now I somehow fixed the issue with drivers trough the CMD and DDU. Now when I connected my R9 270X i have some weird flashing horizontal lines over the screen. GTX 550 Ti worked without problems and flashing lines. Maybe the issue in the first place was a problem inside the R9 graphic. Maybe the time has come for R9 to rest in piece. 😞
 
Reactions: JohnBonhamsGhost
more than likely the card has just recently malfunctioned. if you have the option, test the 270X in another system to make sure it is definitely the card having problems.
if it turns out still okay, at least you may get a few bucks for it towards a newer generation GPU.
 

ASK THE COMMUNITY