Jun 12, 2023
So, I have a Ryzen 5 1600AF (Zen+) processor and an MSI B450M PRO-VDH MAX motherboard. Before the upgrade, I had two Crucial green RAM sticks running at 2400 MHz, and I replaced them with G.Skill Ripjaws V 3200 (2x8GB) with 16 timings. I immediately enabled XMP in the BIOS, and everything started up and worked fine. However, after some time, I decided to restart the PC, and it got stuck at the "Welcome" logo. About 5 seconds after it froze, the monitor, keyboard, and mouse backligh turned off, while the fans inside the PC kept spinning. The only solution was a forced reboot. This happened a few more times(it happens randomly), and I noticed that it occurred either at the "Welcome" screen, during the motherboard logo stage, or a few seconds after the "Welcome" screen.

I have the latest BIOS version installed, downloaded from the manufacturer's website, and I also have the chipset drivers from there. The graphics card has the latest driver from AMD website(RX 570).

Here's what I've tried so far:
  • Ran HCI MemTest for about half an hour
  • Ran OCCT stress test on RAM for half an hour
  • Ran MemTest5 with different configurations: absolut@anta777 config 10 cycles, some cycles on 1usmus_v3, some cycles on MT
  • Played heavy games like Cyberpunk 2077, Metro Exodus, Mount & Blade II: Bannerlord, Rise of the Tomb Raider
  • Ran MemTest86 from a bootable flash drive for a full pass
  • Ran y-cruncher VST for half an hour and 5 billion Pi Benchmark
  • Ran AIDA64 stress test for about 15 minutes and tested memory and CPU speed multiple times
  • Tested file compression with WinRAR on large files
  • Downgraded the BIOS to an older version
  • Checked the Windows Event Log, which showed an SCEP certificate error, but it disappeared after disabling TPM in the BIOS. No other errors were found there
And none of these tests caused the PC to freeze or show any errors. All tests ran without a single error...

Please, help me! What could be the problem? Should I return the RAM to the store?


Welcome to the forums, newcomer!

I have the latest BIOS version installed
Would be a good idea to mention the BIOS version instead of stating latest. We get a lot of threads here whereby after verifying the version, there was one ore more versions pending update.

Did you clear the CMOS with every BIOS upgrade/downgrade?

When posting a thread of troubleshooting nature, it's customary to include your full system's specs. Please list the specs to your build like so:
CPU cooler:
include the age of the PSU apart from it's make and model.