Jul 1, 2016
Hello friends I’m new here and I have a REALLY confusing hardware problem, so this is a gonna a bit long.

tl;dr, I think my RX 470 is locked to Ryzen systems and will not work with Intel systems.


From the Philippines. I bought my girlfriend an RX 470 that she could use in her new build until GPU prices calm down. I found the card secondhand from a seller with many positive reviews, and he proved to me (with timestamps even) that the card was in good working order and could play games, could do anything really. All this to say that the seller seemed solid.

My old setup:
I received the card, it was old, had faded gold pins, but otherwise looked normal. I plugged it into my OLD system with an i5-4460, Asus B-85 Pro Gamer, 8 gb RAM, Windows 10, to test the card. The system would turn on, GPU lights on, fans spinning, but no display. Reseated the RAM and the card, still no display. It would show up as no signal on my monitor. I plugged the HDMI cable into my motherboard with the 470 still attached, and found that the GPU was not detected at all even when running off of my integrated graphics. AMD’s driver software that detects your GPU for driver updates wasn’t even finding it.

My current setup:
My current personal system has a Ryzen 7 5800X, Asus X570-F, 32 gb RAM, Windows 10, and a GTX 1080 FE. I swapped out the 1080 for the 470 to see if it would work, and it did! The card worked perfectly fine in my current system. I could play games and do anything.
I thought it wasn’t working on my old setup because maybe the mobo was dying, so I decided to let it go and hope for the best until my girlfriend’s setup arrived.

GF’s setup:
A couple weeks later, my gf’s parts finally came together and we set up an i5-10400F, MSI B560M Pro-VDH Wifi, 16 gb RAM, Windows 10. Plugged the 470 into her setup and boom, no display, exact same problem as with my old setup. It would light up, fans would spin, but no display. I tried placing my GTX 1080 into her system and THAT worked.
I went to Reddit to ask around and somebody suggested the possibility that the card may somehow be locked to Ryzen systems being that it failed to work in two Intel systems. I asked the seller what his system was, the one he had the 470 running in, and sure enough, he had a Ryzen 5 1600, B350M. This just furthered one Redditor’s theory that somehow it isn’t compatible with Intel systems.
My original theory was that my X570-F could detect the card because being that it’s a higher-end mobo, it was more sensitive to even faded contacts? Although that makes no sense with the original seller’s mobo being an older, cheaper B350M.

As of now, I have given my girlfriend my GTX 1080 to use for now until I can figure out what to do with her RX 470. The 470 works in my system so it’s currently plugged into my R7 5800X, X570 system. The temps are fine, even better than my 1080 FE’s temps.

What I have tried:
I’ve tried a lot of things to try and solve this so I can’t remember all, but here’s what I can recall right now:
  • Reseating RAM
  • Reseating GPU
  • Using HDMI, Display port, VGA, none worked
  • Updating drivers (could not because AMD software could not detect the RX 470)
  • DDU-ing NVIDIA drivers
  • Updating BIOS
  • Resetting BIOS to default
  • Removing CMOS battery and replacing it after 2-3 minutes, did it again for 5 minutes.
  • Cleaning the contacts with an eraser twice, with and without alcohol
  • Checking if integrated graphics were enabled (it wasn’t)
  • Checking if Resizable Bar Support was enabled (it wasn’t)
  • Enabling “Normal Setup” on msconfig instead of Selective Startup
  • Booting from Integrated Graphics on my old Intel system, entered device manager to check if the RX 470 was detected, but it wasn't
I have considered having someone re-apply the gold pins, but I did my best to budget for this and I would rather find another way that doesn’t involve paying hahaha

Thank you so much for any help you can provide!
I will reply to you as soon as possible, I'm studying for an ophthalmology exam at the same time hahaha

Pix of the RX 470 contacts:
View: https://imgur.com/a/FNYZvq3

Could it not working with 2 intel systems and working with 2 Ryzen systems simply be a coincidence and that the old contacts of the GPU are to blame?


Win 11 Master
Last edited: