Question gpu doesnt get detected when booting computer

Apr 12, 2022
14
1
15
0
gpu not detecting on my mobo even though it was working fine before??? computer crashed (no blue screen) wouldnt turn on, finally got it to turn on, half an hour later it wont shut off. i come back and it now cant detect the gpu. i shut it off so many times and i sent back the gpu but apparently there isnt any problem??? theyre sending it back and i dont know what to do. mobo- rog strix b550-f (wifi) and gpu- msi geforce rtx 3050

oh also full computer specs
mobo + gpu listed above
ram- corsair vengence pro 32 gigs (2x 16 gigs)
psu- corsair cx650 80+ bronze
cpu- amd ryzen 5 5600x
ssd- Corsair Force Series MP600 2TB Gen4 PCIe X4 NVMe M.2 SSD
also monitor- asus vg248qg

**i am also using windows 11 if that changes anything, had some problems with it before even thought my computer is compatible with it.
 
Last edited:
Apr 12, 2022
14
1
15
0
i upgraded to windows 11 around 2 weeks ago and i didnt like it and i started having some issues with my computer. recently it stopped working all together and the mobo wasnt detecting gpu (as i explained in an earlier thing on my page) we thought gpu had a problem so we sent it back (it worked fine, waiting for it to come back now) and in the process of waiting for the gpu i found out that windows 11 couldve done something to bios and potentially changed everything. it worked for a few days until it didnt. i found some other people with the same issue but im wondering if its windows 11 that changed it or if something wrong with my mobo.

dont know if u need full system specs but here
mobo- asus rog strix b550-f (wifi)
gpu- msi gaming geforce rtx 3050
ram- corsair vengence pro 32 gigs (2x 16 gigs)
psu- corsair cx650 80+ bronze
cpu- amd ryzen 5 5600x
ssd- Corsair Force Series MP600 2TB Gen4 PCIe X4 NVMe M.2 SSD
also monitor- asus vg248qg

even if it is something with bios/my gpu how would i reset both?
 
Windows normally doesn't touch BIOS settings, and if it does, all Windows can really do is generic administrative stuff like reset the settings or something. Though this is conjecture based on every motherboard model being different so there's no real way for the OS to know what exactly to poke at, except for common features.

In any case, if you want to reset BIOS, while the computer is off either:
  • Find out if your motherboard has a settings reset button you have to hold down or a jumper you have to short for a few seconds
  • Pop out the coin cell battery and wait a minute. You can shorten this by shorting the terminals.
 
Apr 12, 2022
14
1
15
0
e
Windows normally doesn't touch BIOS settings, and if it does, all Windows can really do is generic administrative stuff like reset the settings or something. Though this is conjecture based on every motherboard model being different so there's no real way for the OS to know what exactly to poke at, except for common features.

In any case, if you want to reset BIOS, while the computer is off either:
  • Find out if your motherboard has a settings reset button you have to hold down or a jumper you have to short for a few seconds
  • Pop out the coin cell battery and wait a minute. You can shorten this by shorting the terminals.
epic thank you
 
Apr 12, 2022
14
1
15
0
this is connected to my other posts cuz i cant find the issue so im now blaming it on my mobo lol, full story on my other posts. anyways got my gpu back (was originally gonna send it back for a new one, but they tested it and it worked completely fine. ) put it in, tried resetting bios (i really hope i didnt kill my pc lol) and it did absolutely nothing, still wouldnt detect the gpu to boot. im kinda stumped cuz i dont wanna send it back, and everything lights up and my only issue is the gpu not being detected to boot. ive done so much research and i couldnt fine anything other than "make sure everythings plugged in" ;/ also weird thing about this, it was working fine before. i built this pc around the middle/end of march.

system specs
mobo- asus rog strix b550-f (wifi)
gpu- msi gaming geforce rtx 3050
ram- corsair vengence pro 32 gigs (2x 16 gigs)
psu- corsair cx650 80+ bronze
cpu- amd ryzen 5 5600x
ssd- Corsair Force Series MP600 2TB Gen4 PCIe X4 NVMe M.2 SSD
also monitor- asus vg248qg

please help, this is my only hope lol
 
Apr 12, 2022
14
1
15
0
yeah ive seen that, the button is hidden somewhere lol, but i tried resetting bios by taking the cmos battery out and shorting the pins (forgot what theyre called even tho i just saw them lol)
 

ASK THE COMMUNITY