Dec 13, 2018
i'm using a desktop with a core i5-4570 cpu on a gigabyte ga-h81m-s2pv motherboard and 2x4gb ddr3 ram operating windows 8.1 pro. recently i installed gigabyte app centre from their website and it updated 8 of my drivers. then after several hours suddenly the display went jerkingly blurred with black lines blinking all over on a white background. i restarted the pc by button but the pc wasn't starting. it didnt even go to boot menu or blue screen. then i plugged out everything and opened it and removed one of the 4gb ram. then when i turned it on it shows bios corrupted and itself used backup bios to boot successfully. but whenever i try to install the ram back, it doesnt start....

[this ram was left unused for sometimes and when i reinstalled it back 4months ago the pc wasn't starting and when i tried with this stick removed, the pc quoted bios corrupted and it used backup bios to boot successfully. but when i tried again inserting it back on, it was successfully integrated into the system and didn't cause any trouble and was running smoothly since then]

i have no idea what is causing it.. i installed intel hd graphics driver from intel website a while ago as i remember it was one of the drivers updated by appcentre and considering the display issue i faced last time. i uninstalled the app centre too. can it be an issue with the driver update or something else??? i can't remember all the drivers updated. realtek hd audio and realtek gbie ethernet controller was certainly among them and something like rapid memory maybe was among them.

please give me some suggestion and ask me if you need any details to give me the solution. i need to use the other ram too coz you know only 4gb isn't enough for anything..
Last edited:


Nov 1, 2014
Some noob advice...swap out the working memory stick with the suspected bad memory stick to see if it is the memory stick itself. Check all components to see if they're seated correctly, especially the graphics card. Sounds like the problem started after installing the updates, try uninstalling them one by one. Can always re-install them later. Is the bios up to date? I searched "driver update history" and found https://www.makeuseof.com/tag/view-recently-updated-drivers-windows/ but I'm sure there's other websites with the similar instructions on how to track them down.
Again, not a computer expert, but I've always done upgrades (software and hardware) one item at a time to see the improvements or resulting problems that each one caused.


I have heard of Intel® Rapid Storage Technology driver causing problems before. Did you install Microsoft .NET Framework 4.5 first like it says? Which version is your motherboard, 1,2 or 3? I think the current version of Net Framework is 4.8 now. It is also used for the APP center. A corrupted Bios can be caused by a bad power supply also (bad filtering DC voltage)